TQSL Installation

2 posts / 0 new
Last post
NZ0T
TQSL Installation

I see that the latest TQSL is V2.4.3. I currently have 2.3.1 installed which is what synaptic has available for my Mint 19.1. A tar is available but with my limited Linux skills I have no idea how to compile and install it. Can someone help with a step by step procedure on how to compile and install the latest TQSL or point me towards one? V 2.3.1 seems to work fine for me but I would like to have the latest installed if I can figure out how to do it.

73, Bill NZ0T

PA3GOS
TQSL Installation

Hi Bill,

I just tried to go that route. Seems on my Mint 18.3 tqsl is missing some uninstallable dependencies.

Nevertheless, here is what you might try:

1. Unpack the tarball to a directory in your homedirectory. Remember where!
2. Now find the tqsl 2.4.3 folder (directory) you just created by unpacking.
3. Rightclick on the folder and choose "Open in terminal".
4. In the terminal, type "Cmake . " without the quotes. If you get an error that cmake could not be found: type "sudo apt-get install cmake". Again, without the quotes.
5. If all goes well, type "make"
6. If no errors occurred, type "make install"
7. Done

Mind you, after the typed commands, hit "enter". And while typing, forget the quotes, also where i didn't mention that.
Also, between cmake and the dot is a space. Might not be clear when you read this. Maybe you can copy the commands from here and paste them in the terminal.

73, Tjalling PA3GOS