rigctld not working wwith ts-570

11 posts / 0 new
Last post
N3MOW
rigctld not working wwith ts-570

Hello,

Had CQRLog working with Mint 17.3. Using serial to usb cable. Now after I updated to Mint 19.1 trx control does not work. Same setup. No changes to rig setup. Entered same parameters in CQRLog as before. Data speed 57.6 other params default. dmesg | grep usb shows cable on /dev/ttyUSB0 but I cannot see the st-570 in the list.

All help is appreciated.

Marty, N3MOW

k8wdx
k8wdx's picture
Terminal

Terminal
sudo adduser "username" (with out the quotes) reboot.

I seem to forget this step after upgrading.

Tom K8WDX

N3MOW
TS 570 not working in tx control

Thanks for your response. What user name would you suggest? I am using CQRLog as root during setup. Please clarify.

73
Marty N3MOW

Marty, N3MOW

PA1SBM
PA1SBM's picture
rigctld not working wwith ts-570

In a terminal do:

rigctld -l | grep 570D

It will show:
204 Kenwood TS-570D 0.9.2 Stable

regards,
Alex, PA1SBM

N3MOW
TS570

Command returns list of rigs. Initrigs3 kenwood. Rig-register (204). Rigctld is in /user/bin/rigctld. Rig still does not connect.

73
Marty, N3MOW

Marty, N3MOW

k8wdx
k8wdx's picture
sudo adduser "username"

sudo adduser "username" dialout
(with out the quotes) reboot.
I forgot the dialout above,
"username" this is the name you you used when you set up the PC

Tom K8WDX

N3MOW
ts-570 not working

I am already a member of the dialout group. Got to be something else. Say usb/rs232 cable.

73

Marty, N3MOW

Marty, N3MOW

zl3aau
TS-570 not working

Have a look in the etc/group file. User name should be after dialout, tty and tx. if not edit the file and add user name after each. DonĀ“t forget to reboot your system when finished.
73 John

john-zl3aau

oh1kh
rigctld not working wwith ts-570

HI!

Stop cqrlog if it is running.2116 ? S 0:00 /usr/bin/rigctld -m

Start command console.
1)
Give
ps ax | grep rig (+return)
if you have any lines starting like:
2116 ? S 0:00 /usr/bin/rigctld -m
2)
Give:
kill -9 2116
NOTE! You will have different number than 2116. Use your number instead of 2116

3)
repeat step 1) to see that there is no more that kind of line. If is, go step 2) again until you get rid of rigctld processes.

4)
Give:
rigctl -m 216 -s 57600 -r /dev/ttyUSB0 -vvvvv (+return)

NOTE! Your rig may be -m 216 (ts-570S) or -m 204 (ts-570D),
NOTE! do type rigctl not rigctld

Look at messages it gives. Any errors? What kind?
When (if) you get prompt "Rig command:" give
f (+return)
NOTE! low case f
You should get current frequency.
give
m(+return)
NOTE! low case m
You should get mode.

Until you can get right frequency and mode with rigctl there is no use to try cqrlog.
If you do not get rigctl working reason is at your:
serial port (wrong port name, no permission to use port etc.. This you will see when starting rigctl as serial device error.
or
rig CAT cable or rig CAT socket (internal hardware fault in CAT output circuit or PC serial port device). This you will see if rigctl starts ok, but timeouts when f-command is given.

--
Saku
OH1KH

oh1kh
rigctld not working wwith ts-570

HI !
ignore my last message start;

Stop cqrlog if it is running.2116 ? S 0:00 /usr/bin/rigctld -m

It should be:
Stop cqrlog if it is running.

I have faulty button in mouse wheel that paste lines when rolling.

--
Saku
OH1KH

N3MOW
SOLVED TS-570 not working

Saku,

Forgive the delay in my getting back to you. Adding the tty group was the answer. I now have CQRLog running with rigctld. I'm able to connect to the rig using CQRLog and then to wsjt-x so far without problem. I have just installed js8call and will test it using CQRLog to start rigctld. Should work.

Thanks for your help.

73

Marty, N3MOW

Marty, N3MOW