Issue upgrading to version 2.5.0

20 posts / 0 new
Last post
EA4HEA
Issue upgrading to version 2.5.0

Hi

Happy today when I typed sudo apt-get update ... upgrade and I realised that there was a new version of cqrlog. My current version is 2.4.0(134).
Unfortunatelly my happiness diassapered in seconds ... I was not able to upgrade it. Please find below the error output. I am runnig Ubunto 20.04 on a brand new Lenovo laptop.

Preparando para desempaquetar .../cqrlog_2.5.0-1~focal_amd64.deb ...
Desempaquetando cqrlog (2.5.0-1~focal) sobre (2.4.0-3) ...
dpkg: error al procesar el archivo /var/cache/apt/archives/cqrlog_2.5.0-1~focal_amd64.deb (--unpack):
intentando sobreescribir `/usr/share/cqrlog/changelog.html', que está también en el paquete cqrlog-data 2.4.0-3
dpkg-deb: error: el subproceso copiado fue terminado por la señal (Tubería rota)

Changes removed from /etc/apparmor.d/local/usr.sbin.mysqld
Restarting apparmor...

Changes removed from /etc/apparmor.d/usr.sbin.mysqld

File /etc/apparmor.d/local/usr.sbin.mysqld was modified, restarting apparmor

Se encontraron errores al procesar:
/var/cache/apt/archives/cqrlog_2.5.0-1~focal_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Please help!

Regards

K5KV
INSTALL 2.5.0 FAILED

benny@benny-Ratel-Performance:~$ sudo add-apt-repository ppa:ok2cqr/ppa;sudo apt-get update;sudo apt-get install cqrlog
[sudo] password for benny:
CQRLOG is an advanced ham radio logger based on MySQL database. Provides radio control based on hamlib libraries (currently support of 140+ radio types and models), DX cluster connection, HamQTH/QRZ callbook (XML access), a grayliner, internal QSL manager database support and a most accurate country resolution algorithm based on country tables developed by OK1RR. CQRLOG is intended for daily general logging of HF, CW & SSB contacts and strongly focused on easy operation and maintenance.
More info: https://launchpad.net/~ok2cqr/+archive/ubuntu/ppa
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 http://us.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://security.ubuntu.com/ubuntu focal-security InRelease
Hit:3 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:4 http://ppa.launchpad.net/ok2cqr/ppa/ubuntu focal InRelease
Reading package lists... Done
Hit:1 http://us.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:3 http://security.ubuntu.com/ubuntu focal-security InRelease
Hit:4 http://ppa.launchpad.net/ok2cqr/ppa/ubuntu focal InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
chromium-browser-l10n chromium-codecs-ffmpeg-extra command-not-found-data
cpp-5 cqrlog-data dcraw debian-archive-keyring g++-7 gcc-8-base:i386
gir1.2-gdata-0.0 gir1.2-gtksource-3.0 gir1.2-mutter-2 gnome-software-common
guile-2.0-libs icoutils iputils-arping kde-runtime-data kde-style-breeze
kdelibs5-data libapt-pkg-perl libargon2-0 libart-2.0-2
libasync-mergepoint-perl libboost-filesystem1.65.1 libboost-iostreams1.65.1
libboost-locale1.65.1 libboost-system1.65.1 libboost-thread1.65.1 libc-ares2
libcdio17 libcharls1 libclass-method-modifiers-perl libclass-xsaccessor-perl
libcomerr2:i386 libcrystalhd3 libcwidget3v5 libdigest-bubblebabble-perl
libdlrestrictions1 libdouble-conversion1 libdrm-dev libdvdread4
libegl1-mesa-dev libevent-2.1-6 libexiv2-14 libexporter-tiny-perl
libffi6:i386 libfile-copy-recursive-perl libfile-find-rule-perl
libfluidsynth1 libfont-ttf-perl libg15daemon-client1 libgdbm5 libgeoclue0
libgeoip1 libgeos-3.6.2 libgeotiff2 libgfortran3 libgfortran4
libgles2-mesa-dev libglew2.0 libglvnd-core-dev libgmime-3.0-0
libgnome-desktop-3-17 libgpgme++2v5 libgssdp-1.0-3 libgupnp-1.0-4
libgutenprint2 libhttp-parser2.7.1 libhunspell-1.6-0 libicu60 libicu60:i386
libilmbase12 libimport-into-perl libindicator7 libio-pty-perl libip4tc0
libip6tc0 libipc-run-perl libiptc0 libisc-export169 libisl15 libisl19
libjson-maybexs-perl libjte1 libkf5style5 liblensfun-data-v1
liblinux-epoll-perl liblist-moreutils-perl liblivemedia62 libllvm10
libllvm10:i386 libllvm9 libllvm9:i386 liblog4cplus-1.1-9 liblouis14
liblouisutdml8 liblvm2app2.2 liblvm2cmd2.02 liblwres160
libmagickcore-6.q16-3 libmecab2 libmicrodns0 libminiupnpc10
libmodule-implementation-perl libmpx0 libmutter-2-0 libmysofa0
libmysqlclient20 libncurses5:i386 libnet-ip-perl libnfs11 libnode64
libnss-myhostname libnumber-compare-perl libokular5core8 libopencv-core3.2
libopencv-imgproc3.2 libopenvdb5.0 liborcus-0.13-0 libpackage-stash-perl
libpath-tiny-perl libperlio-gzip-perl libplacebo4 libprocps6 libproj12
libprotobuf-lite10 libprotobuf10 libpython3.6 libpython3.6-minimal
libpython3.6-stdlib libqpdf21 libqt5script5 libraw16 libreadline7
libref-util-perl libref-util-xs-perl librhino-java librole-tiny-perl
libsane1 libsane1:i386 libsereal-decoder-perl libsereal-encoder-perl
libsndio6.1:i386 libspeexdsp1:i386 libstdc++-7-dev libstk-4.5.0
libstreams0v5 libsub-exporter-progressive-perl libsub-identify-perl
libtagsoup-java libtest-fatal-perl libtest-refcount-perl libtext-glob-perl
libtext-levenshtein-perl libthunarx-2-0 libtiff5-dev libtinfo5:i386
libtype-tiny-perl libtype-tiny-xs-perl libunicode-utf8-perl libupnp6
libusbmuxd4 libvpx5 libwayland-egl1-mesa libwxgtk3.0-0v5 libx264-152
libxcb-dri2-0-dev libxcb-dri3-dev libxcb-render0-dev libxcb-shape0-dev
libxcb-sync-dev libxcb-xfixes0-dev libxdamage-dev libxdg-basedir1
libxfcegui4-4 libxfconf-0-2 libxfixes-dev libyaml-cpp0.5v5
libyaml-libyaml-perl libzeitgeist-1.0-1 mate-desktop-common mesa-common-dev
nodejs nplan orage orage-data oxygen-icon-theme patchutils
phonon-backend-gstreamer-common python-bzrlib python-configobj
python-configparser python-defusedxml python-entrypoints python-fasteners
python-imaging python-keyring python-lzma python-monotonic python-olefile
python-paramiko python-pil python-psutil python-secretstorage
python-simplejson python-sip python-soappy python-wstools python-zeitgeist
python3-asn1crypto python3-bs4 python3-feedparser python3-lxml python3-oauth
python3-pycurl python3-pysimplesoap python3-soupsieve python3-zope.interface
python3.6-doc qml-module-qttest qpdf qtcore4-l10n
qtdeclarative5-qtquick2-plugin t1utils ubuntuone-client-data
unity-lens-files unity-lens-music unity-lens-video unity-scope-video-remote
wx3.0-headers x11proto-input-dev x11proto-kb-dev xplanet xplanet-images
xubuntu-icon-theme
Use 'sudo apt autoremove' to remove them.
The following packages will be upgraded:
cqrlog
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/14.9 MB of archives.
After this operation, 21.4 MB of additional disk space will be used.
(Reading database ... 364424 files and directories currently installed.)
Preparing to unpack .../cqrlog_2.5.0-1~focal_amd64.deb ...
Unpacking cqrlog (2.5.0-1~focal) over (2.4.0-3) ...
dpkg: error processing archive /var/cache/apt/archives/cqrlog_2.5.0-1~focal_amd64.deb (--unpack):
trying to overwrite '/usr/share/cqrlog/changelog.html', which is also in package cqrlog-data 2.4.0-3
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)

Changes removed from /etc/apparmor.d/local/usr.sbin.mysqld
Restarting apparmor...

Job for apparmor.service failed because the control process exited with error code.
See "systemctl status apparmor.service" and "journalctl -xe" for details.
invoke-rc.d: initscript apparmor, action "restart" failed.
● apparmor.service - Load AppArmor profiles
Loaded: loaded (/lib/systemd/system/apparmor.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2021-01-16 22:52:44 CST; 5ms ago
Docs: man:apparmor(7)
https://gitlab.com/apparmor/apparmor/wikis/home/
Process: 19088 ExecStart=/lib/apparmor/apparmor.systemd reload (code=exited, status=1/FAILURE)
Main PID: 19088 (code=exited, status=1/FAILURE)

Jan 16 22:52:44 benny-Ratel-Performance apparmor.systemd[19124]: Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
Jan 16 22:52:44 benny-Ratel-Performance apparmor.systemd[19126]: AppArmor parser error for /etc/apparmor.d in /etc/apparmor.d/usr.sbin.mysqld at line 15: syntax error, unexpected TOK_CLOSE, expecting $end
Jan 16 22:52:44 benny-Ratel-Performance apparmor.systemd[19128]: Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
Jan 16 22:52:44 benny-Ratel-Performance apparmor.systemd[19169]: Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
Jan 16 22:52:44 benny-Ratel-Performance apparmor.systemd[19216]: AppArmor parser error for /etc/apparmor.d/usr.sbin.mysqld in /etc/apparmor.d/usr.sbin.mysqld at line 15: syntax error, unexpected TOK_CLOSE, expecting $end
Jan 16 22:52:44 benny-Ratel-Performance apparmor.systemd[19217]: Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
Jan 16 22:52:44 benny-Ratel-Performance apparmor.systemd[19088]: Error: At least one profile failed to load
Jan 16 22:52:44 benny-Ratel-Performance systemd[1]: apparmor.service: Main process exited, code=exited, status=1/FAILURE
Jan 16 22:52:44 benny-Ratel-Performance systemd[1]: apparmor.service: Failed with result 'exit-code'.
Jan 16 22:52:44 benny-Ratel-Performance systemd[1]: Failed to start Load AppArmor profiles.

Changes removed from /etc/apparmor.d/usr.sbin.mysqld

File /etc/apparmor.d/local/usr.sbin.mysqld was modified, restarting apparmor

Job for apparmor.service failed because the control process exited with error code.
See "systemctl status apparmor.service" and "journalctl -xe" for details.
invoke-rc.d: initscript apparmor, action "restart" failed.
● apparmor.service - Load AppArmor profiles
Loaded: loaded (/lib/systemd/system/apparmor.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2021-01-16 22:52:45 CST; 5ms ago
Docs: man:apparmor(7)
https://gitlab.com/apparmor/apparmor/wikis/home/
Process: 19272 ExecStart=/lib/apparmor/apparmor.systemd reload (code=exited, status=1/FAILURE)
Main PID: 19272 (code=exited, status=1/FAILURE)

Jan 16 22:52:45 benny-Ratel-Performance apparmor.systemd[19289]: Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
Jan 16 22:52:45 benny-Ratel-Performance apparmor.systemd[19291]: AppArmor parser error for /etc/apparmor.d in /etc/apparmor.d/usr.sbin.mysqld at line 15: syntax error, unexpected TOK_CLOSE, expecting $end
Jan 16 22:52:45 benny-Ratel-Performance apparmor.systemd[19293]: Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
Jan 16 22:52:45 benny-Ratel-Performance apparmor.systemd[19334]: Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
Jan 16 22:52:45 benny-Ratel-Performance apparmor.systemd[19378]: AppArmor parser error for /etc/apparmor.d/usr.sbin.mysqld in /etc/apparmor.d/usr.sbin.mysqld at line 15: syntax error, unexpected TOK_CLOSE, expecting $end
Jan 16 22:52:45 benny-Ratel-Performance apparmor.systemd[19383]: Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
Jan 16 22:52:45 benny-Ratel-Performance apparmor.systemd[19272]: Error: At least one profile failed to load
Jan 16 22:52:45 benny-Ratel-Performance systemd[1]: apparmor.service: Main process exited, code=exited, status=1/FAILURE
Jan 16 22:52:45 benny-Ratel-Performance systemd[1]: apparmor.service: Failed with result 'exit-code'.
Jan 16 22:52:45 benny-Ratel-Performance systemd[1]: Failed to start Load AppArmor profiles.

Errors were encountered while processing:
/var/cache/apt/archives/cqrlog_2.5.0-1~focal_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

dl1mtg
dl1mtg's picture
Issue upgrading to version 2.5.0

There seems to be an package-issue with cqrlog in Ubuntu or derivates.

You can find the package cqrlog and cqrlog-data using Ubuntu derivates
But the package cqrlog-data is not present in the cqrlog-ppa.

Whats included in cqrlog-data?
https://packages.ubuntu.com/groovy/all/cqrlog-data/filelist

/usr/share/cqrlog ... no config or other important files!

What can yo do?
Make a backup :-)
Deinstall cqrlog-data!

sudo apt-get remove cqrlog-data

Then cqrlog is useable in version 2.5.0
sudo apt-get upgrade

I'am using Linux Mint 20.1 Ulyssa, based also on Ubuntu and it worked!

--
73 de Martin, DL1MTG

EA4HEA
Issue upgrading to version 2.5.0

Interesting. And any impact on funcionality? Is it 100% functional? It's amazing that it works removing parts of the software.

Regards

K5KV
REMOVING CQRLOG-DATA WORKS BUT...

MARTIN

THANKS FOR THE TIP. REMOVING CQRLOG-DATA DID GET 2.5.0 RUNNING. WHEN I CLICK THE HELP BUTTON AND THEN HELP INDEX, I GET AN ERROR MESSAGE "Browser CHROMIUM not found".

THIS MESSAGE APPEARS EVEN IF CHROMIUM IS RUNNING ON THE SAME WORKSPACE. ANYONE HAVE ANY IDEAS ON THE FIX FOR THE MISSING HELP IN CQRLOG?

dl1mtg
dl1mtg's picture
REMOVING CQRLOG-DATA WORKS BUT...

Hi again,

there might be an unconfigured web browser in your cqrlog?

Try the following:
Menu -> File -> Preferences -> Program -> "Web browser for cqrlog"

At my installation: /usr/bin/firefox

Check for the full path to chromium and copy & paste it in this field.
Is it working now?

--
73 de Martin, DL1MTG

K5KV
CQRLOG HELP NOT WORKING

HI MARTIN ET AL

I PUT /usr/bin/chromium-browser IN THE PREFERENCES BOX. IT STILL GIVES THE ERROR MESSAGE AS BEFORE ABOUT CHROMIUM. I EVEN TESTED /usr/bin/chromium-browser IN A TERMINAL AND IT WORKS. I TRIED REINSTALLING CQRLOG 2.5.0. BUT THAT DID NOT HELP EITHER.

I CAN JUST GOOGLE CQRLOG HELP AND GET TO IT SO NO SWEAT. THANKS FOR YOUR HELP. AT LEAST 2.5.0 WORKS.

dl1mtg
dl1mtg's picture
REMOVING CQRLOG-DATA WORKS BUT...

Hello Benson,

I'am glad to hear version 2.5.0 is working now.

Sorry to say: I have no clue why installed 2.5.0 help files are not working.
On the www.cqrlog.com page the help files are not up2date - seems they hang at version 2.0.0

Please be patient and wait for an official answer from the cqrlog-team.

--
73 de Martin, DL1MTG

dl1mtg
dl1mtg's picture
Issue upgrading to version 2.5.0

Hi again,

there is no impact.

cqrlog-data includes the following files: /usr/share/cqrlog/...
These are help files, icons...there is no binary!

Last but not least: this is all included in the package cqrlog when using the cqrlog-ppa to get version 2.5.0

--
73 de Martin, DL1MTG

EA4HEA
Issue upgrading to version 2.5.0

Yes, it worked!!!

Thanks!!! and 73!!!

ww9jd
I used

I used

sudo add-apt-repository ppa:ok2cqr/ppa;sudo apt-get update;sudo apt-get install cqrlog

on my ubuntu 20.10 system and also get the error

Unpacking cqrlog (2.5.0-1~groovy) over (2.4.0-3) ...
dpkg: error processing archive /tmp/apt-dpkg-install-8rzNIt/10-cqrlog_2.5.0-1~groovy_amd64.deb (--unpack):
trying to overwrite '/usr/share/cqrlog/changelog.html', which is also in package cqrlog-data 2.4.0-3
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)

Changes removed from /etc/apparmor.d/local/usr.sbin.mysqld
Restarting apparmor...

Changes removed from /etc/apparmor.d/usr.sbin.mysqld

File /etc/apparmor.d/local/usr.sbin.mysqld was modified, restarting apparmor

Errors were encountered while processing:
/tmp/apt-dpkg-install-8rzNIt/10-cqrlog_2.5.0-1~groovy_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Didn't I use "cqrlog-ppa to get version 2.5.0"?

73,
Rick WW9JD

dl1mtg
dl1mtg's picture
Issue upgrading to version 2.5.0

Hello Rick,

you have successfully added the cqrlog-ppa.
Please have a look into the error message while doing the update:

Unpacking cqrlog (2.5.0-1~groovy) over (2.4.0-3) ...
dpkg: error processing archive /tmp/apt-dpkg-install-8rzNIt/10-cqrlog_2.5.0-1~groovy_amd64.deb (--unpack):
trying to overwrite '/usr/share/cqrlog/changelog.html', which is also in package cqrlog-data 2.4.0-3
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)

You've also installed cqrlog-data from Ubuntu.
And this package has to be removed!

All removed files are included in cqrlog using the cqrlog ppa

--
73 de Martin, DL1MTG

NZ0T
Help Please

I did a fresh install of Linux Mint 20 Cinnamon a few weeks ago and after some help from Saku I was able to get cqrlog 2.4 installed and working again. I have since upgraded to Mint 20.1 and 2.4 is still working fine. Apparently I did not add the cqrlog ppa when I installed Mint 20 so this is the first I knew of 2.5 being available. I would like to upgrade to 2.5 but from what I am reading in this thread there are issues with installing it. And I'm confused as to how to go about installing it -my apologies but I'm easily confused!

Could someone please post an easy step by step procedure on how to properly install 2.5 on Mint 20.1?

73, Bill NZ0T

NZ0T
I should have said I am

I should have said I am running Linux Mint 20.1 Ulyssa.

dl1mtg
dl1mtg's picture
Help Please

Hello Bill,

you can try the following - but be prepared to have a backup and some linux skills to solve unwanted effects.
Otherwise: wait for official support!

I use Linux Mint Linux Mint 20.1 (Ulyssa) 64Bit

Use the following command to add the PPA:
sudo add-apt-repository ppa:ok2cqr/ppa;sudo apt-get update;sudo apt-get install cqrlog

Then there might be an installation error.

This is because the Ubuntu-CQRLOG-Packages have to parts: cqrlog and cqrlog-data
The Ubuntu Packages only includes help files and some iinitial cqrlog files, no binary to run cqrlog at all.
In my installation it was safe to remove cqrlog-data

You can remove cqrlog-data with the following command:
sudo apt-get remove cqrlog-data

And then install cqrlog again:
sudo apt-install cqrlog

You should see a cqrlog 2.5.0 installation without any errors.
Give it a try when you're keen enough to do this :-) No warranty...

--
73 de Martin, DL1MTG

NZ0T
Martin,

Martin,

Thank you, that worked and 2.5 is working great!

73, Bill NZ0T

dl1mtg
dl1mtg's picture
SOLVED: Issue with Ubuntu / Mint and cqrlog 2.5.0

Hello Bill,

glad to hear it is working!

--
73 de Martin, DL1MTG

NZ0T
What was interesting is that

What was interesting is that I loaded the PPA and then tried to install 2.5 with sudo apt-get install cqrlog and got the error. So I then removed cqrlog-data with sudo apt-get remove cqrlog-data. Then when I ran sudo apt-get install cqrlog I got a message that the latest version 2.5 was already installed. And it ran just fine.

Thanks to all who contributed to the new version - it's great having the Grayline/RBN working again!

73, Bill NZ0T

NZ0T
What was interesting is that

What was interesting is that I loaded the PPA and then tried to install 2.5 with sudo apt-get install cqrlog and got the error. So I then removed cqrlog-data with sudo apt-get remove cqrlog-data. Then when I ran sudo apt-get install cqrlog I got a message that the latest version 2.5 was already installed. And it ran just fine.

Thanks to all who contributed to the new version - it's great having the Grayline/RBN working again!

73, Bill NZ0T

oh1kh
What was interesting is that

Hi Bill !

It seems to be nightmare for Ubuntu users to get 2.5.0 running. That reinforces the feeling that package install is not the best and easiest way. At least in all cases.

I am glad to see all the help Martin, DL1MTG, has done for this!

But the Grayline/RBN.
I think you did run the QT version and so did not get the Grayline spotting by RBN to work. You should have done the compile again few weeks later with fresh source.
There is now workaround where you can link Grayline map to Grayline monitor (the text based view). That makes Grayline map to use RBN monitor's connection and produce the spots to map also with QT5 version.

As said it is a workaround, but does it's job fine. I have been using it without problems.

The idea of compile from source is that you do it on regular basis (a week...to month period ) and that will keep you always with latest updates and fixes.

--
Saku
OH1KH