Error during connection to database

8 posts / 0 new
Last post
dg1bor
Error during connection to database

Hallo, I need help...

On the start of CQRLOG 2.05 cams the following Error:

Error during connection to database:
TMySQL55Connection : Server connect failed.

73 de
Gerhard
DG1BOR

ok2cqr
ok2cqr's picture
Re: Error during connection to database

Hi Gerhard,

what distribution are you using? Did you install mysql client libraries?

73 Petr, OK7AN

dg1bor
Hi Petr,

Hi Petr,

i have installed Debian 8 (Jessi) with the Gnome 3.14.1 GUI
the mysql client is not installed.

73 Gerhard
DG1BOR

ok2cqr
ok2cqr's picture
Re: Hi Petr,

I'm sorry, I'm lost with Debian names. If it's Debian stable, cqrlog won't work because of bug in free pascal compiler. It's in version 3.0 but doesn't include mariadb support. It's strange because the same version from Ubuntu 16.04 has mariadb support build in. We are trying to solve that.

Please use binary packages from Download section https://cqrlog.com/download

VE7GEL
Error during connection to database

I too am experiencing this suddenly with CQRLOG 2.05. I have a separate mysql server. It was all working fine and then suddenly this error message after install of 2.05. I was able to start 2.05 once and after the next start this error appeared.
73
Gordon VE7GEL

VE7GEL
Error during connection to database

After some exploring I found that it seems that some of the db tables' indexing was corrupted, perhaps if cqrlog didn't shutdown correctly or due to some network event (or something). Anyway, a sql dump and reload fixed it. All good now.

Thanks!

dl5ybz
Debian SID /CQRLOG 2.5 / MariaDB

Hi guys,

just tried to set up a debian SID AMD64 box on a virgin metal and run also into mariadb related problems ...

Problem: Error during connection to database: Can not load default MySQL library ("libmysqlclient.so.18" or "libmysqlclient.so"). Check your installation.

System:
Debian SID (unstable) -> mariadb-server 10.1.24-6
mariadb-client :10.1.24-6
Cqrlog: 2.0.5-2 (the debian one..)
also tested : Cqrlog 2.0.5.1 from the downloadarea ( that asked for some more depencies, but ended up in the same problem)

tried to switch to mysql 5.7 ... ( real no fun in Debian SID...) but 5.7.something is not accepted as Client SQL-API.. (guess this is a known problem and MySQL 5.6 is out of reach of the Debian repository ..)

On my old 'SID' computer , CQRLOG 2.4 .. is running wth a 5.6 Mysql Package from 'the past' that have been picked up during the last years... but with a 'out of the box SID install' I have to manged to get a database connection.. neither 'local' nor 'remote' .

This may be a typical 'Debian Unstable transition' problem that will sorted out by next updates.. so take this not as a complain, just as a notice and feedback.

73 de Olaf / DL5YBZ

dl5ybz
Debian SID /CQRLOG 2.5 / MariaDB : fixed

I just fixed my problem by adding 'libmariadbclient-dev-compat' :

apt-get install libmariadbclient-dev-compat

which brings back :

/usr/lib/x86_64-linux-gnu/libmysqlclient.so

(simple way to check: locate libmysqlclient ) (first ' apt-get locate updatedb' to install ... then run 'updatedb' to update the searchdatabase ... )

Now local install works again on my Debian SID 'fresh' installation ;) ...

73 de Olaf /DL5YBZ