Upgrade

18 posts / 0 new
Last post
N4ULE
N4ULE's picture
Upgrade

Trying to upgrade from 2.0.5 to 2.1.0. I am running Linux Mint 17.3 and this is what I have done so far by using these commands,

sudo add-apt-repository ppa:ok2cqr/ppa;sudo apt-get update;sudo apt-get install cqrlog

The above did not work. Looked as if it was working but still had the old ver.

used these commands,

sudo add-apt-repository ppa:ok2cqr/ppa

sudo apt-get update

Still opens the old ver. I am new to Linux and know I am overlooking something so any help would be a big help. Thanks for any help or advice.

73
Jim Quick / N4ULE
n4ule@sc.rr.com

zl3aau
Upgrade

For Mint download the appropriate cqrlog deb file from this site. Find the file in the downloads folder on your computer. Right click on the file and the debi installer will pop up: follow the instructions to install. The next time you run cqrlog it should be the updated version. The debi installer can be used to update programs as long as the file you use is a deb file.
73

john-zl3aau

N4ULE
N4ULE's picture
Download

I downloaded the deb file and right clicked on the file and got an error. Here is a screenshot of what I got,

73
Jim N4ULE

File: 

Jim Quick
n4ule@sc.rr.com

RN6FT
The components for CQRLOG

libssl1.0-dev =>written in the search bar of your browser, click search, get a bunch of sites and choose the package libssl1.0-dev_1.0.2 g-1ubuntu11_i386 and install it first, then cqrlog.deb. It so happened to me. =>The 2nd option: install the terminal emulator instructions are on the Internet 73!!! RN6FT op.Alen

N4ULE
N4ULE's picture
Upgrade

Still looking for help on CQRLOG upgrade to v2.1.0. I am at a lose as to what to do! The a screenshot in my last post is what I get when I try to install the program,

73
Jim N4ULE
n4ule@sc.rr.com

Jim Quick
n4ule@sc.rr.com

oh1kh
Upgrade

I do not have Mint but does these give any help:

Update the package index:
# sudo apt-get update

Install libssl-dev deb package:
# sudo apt-get install libssl-dev

Found with simple googling with words: libssl dev linux mint
https://mint.pkgs.org/lmde/mint-upstream-amd64/libssl-dev_1.0.1j-1_amd64...

At least with my Raspberry-PI, that is one Debian variant like Mint, it is recommended to run sometimes:

sudo apt-get update
and after that
sudo apt-get upgrade

to get the latest packages installed.

--
Saku
OH1KH

N4ULE
N4ULE's picture
repository

Can someone tell me if CQRLOG is in the repository or not? Every time I put this command in the terminal,

sudo add-apt-repository ppa:ok2cqr/ppa;sudo apt-get update;sudo apt-get install cqrlog

It tells me I am up to date. I am trying to upgrade from v2.0.5 to 2.1.0. Thanks for all the advice that I have got but nothing has worked. I am new to Linux. I am running Linux Mint 17.3. Thanks again for any help or advice.

Jim
N4ULE

Jim Quick
n4ule@sc.rr.com

zl3aau
Update

HI Jim ,Iam using mint 18.3and have cqrlog 2.1.0 (oo1) installed.But when I try and reinstall with the debi installer it comes up with the same message. I cannot remember how I fixed the problem. I have set up another machine to investigate and will contact you if I find the answer. It may not be cqrlog but a non updated file in Ubuntu from which Mint is derived. Do you know you can update Mint by clicking on the shield next to the date/time in bottom RH corner and selecting File,this will tell you if an update is available.
73

john-zl3aau

N4ULE
N4ULE's picture
MySQL

I just upgraded from Linux Mint 17.3 to 18.4. After the upgrade I was able to upgrade CQRLOG from 2.0.5 to 2.1.0. Now that is done it also updated MSQL to 5.7.20 so now MySQL will not work. It tells me I need 5.5 for it to work. Here is the last lines to the mysql config file.

171201 15:33:54 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
171201 15:33:54 [Note] Server socket created on IP: '::'.
171201 15:33:54 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them
171201 15:33:54 [ERROR] Native table 'performance_schema'.'cond_instances' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_waits_current' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_waits_history' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_waits_history_long' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_host_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_instance' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_thread_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_user_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_account_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_waits_summary_global_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'file_instances' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'file_summary_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'file_summary_by_instance' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'host_cache' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'mutex_instances' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'objects_summary_global_by_type' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'performance_timers' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'rwlock_instances' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'setup_actors' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'setup_consumers' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'setup_instruments' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'setup_objects' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'setup_timers' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'table_io_waits_summary_by_index_usage' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'table_io_waits_summary_by_table' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'table_lock_waits_summary_by_table' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'threads' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_stages_current' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_stages_history' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_stages_history_long' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_thread_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_account_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_user_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_host_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_stages_summary_global_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_statements_current' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_statements_history' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_statements_history_long' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_thread_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_account_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_user_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_host_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_statements_summary_global_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_digest' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'users' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'accounts' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'hosts' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'socket_instances' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'socket_summary_by_instance' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'socket_summary_by_event_name' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'session_connect_attrs' has the wrong structure
171201 15:33:54 [ERROR] Native table 'performance_schema'.'session_account_connect_attrs' has the wrong structure
171201 15:33:54 [Warning] Failed to load slave replication state from table mysql.gtid_slave_pos: 1146: Table 'mysql.gtid_slave_pos' doesn't exist
171201 15:33:54 [Note] Reading of all Master_info entries succeded
171201 15:33:54 [Note] Added new Master_info '' to hash table
171201 15:33:54 [Note] /usr/sbin/mysqld: ready for connections.
Version: '10.0.31-MariaDB-0ubuntu0.16.04.2' socket: '/home/n4ule/.config/cqrlog/database/sock' port: 64000 Ubuntu 16.04

and also a screenshot

Jim
N4ULE

File: 

Jim Quick
n4ule@sc.rr.com

ok7an
ok7an's picture
Re: MySQL

Hi Jim,

you probably have two MySQL client libraries installed. Use Synaptic or other package manager to remove old version completely.

73 Petr, OK7AN

N4ULE
N4ULE's picture
Thanks

Would to thank everyone for trying to help me with Linux Mint setup. I just can't get it to work. Every time I start CQRLOG it tells me that it is is looking for MYSQL 5.5 and I have 5.7. I don't know how to replace one with the other. I guess I am to old, (82) to learn a new OS. I guess I will go back to the Mac computer. I have WSJT-X and CQRLOG installed on the Mint computer but with the two MYSQL's it will not let me run CQRLOG. Thanks again for all that helped me get to this place. I like the looks of Linux.

73
Jim Quick /N4ULE
n4ule@sc.rr.com

Jim Quick
n4ule@sc.rr.com

oh1kh
Do not give up!

Hi !
Do not give up! You are not too old. There is not a thing called "too old".
If you can make MAC run use it for "relaxing" and having some qsos", but keep the linux project going on.

Have you ever considered to use TeamViewer to get assistance from someone else? It's free for uncommercial use and runs
nice in several OS. If you have never heard about it put word "teamviewer" to google.

With that an Elmer could capture your screen and keys and make needed changes to your system as remote operator.

You just need the Elmer. Probably living at same or near by time zone as you would be convenient.

--
Saku
OH1KH

N4ULE
N4ULE's picture
Termviewer

Saku and Others,

I have put Termviewer on my system and if anyone can help me with CQRLOG it would be a big help. I have WSJT-X working great and I have CQRLOG 2.1 installed and it tells me I need to have the right MYSQL installed and I don't know how to do it. If someone has the time and in my time zone or can log into my computer any time between 9 am to 5 pm EST it would be a big help.

Thanks
Jim Quick
N4ULE

Jim Quick
n4ule@sc.rr.com

oh1kh
Installing cqrlog Lubuntu 17.10

Hi Jim!
Have you had any assistace for your problem yet?

I did install Lubuntu-17.10-desktop-i386 to an old mini laptop with 1Tb hard disk planning to make a simple low power file server with that.
As there is now plenty of room I decided to try plain install of cqrlog for a debian based system.

First installed Petr's repository with the command line from download page.
While it was running I noticed that there was "error 404 not found" when it was seeking cqrlog repository.
How ever, as a result, it installed version 2.0.5(001). I think it comes from some of ubuntu repositories, not from Petr's (as it caused error 404).

That version how ever started ok.

I removed the install and deciced to install from tgz-file cqrlog_2.1.0_i386.tar.gz.
After download I did install with following console commands:

cd /tmp
tar vxf /home/saku/Lataukset/cqrlog_2.1.0_i386.tar.gz
cd cqrlog-2.1.0/
sudo cp -a usr /

Then I got version 2.1.0(001) but at start it went to mysql error and did not run at all.

I manually removed all files copied from tgz to get a clean system for next try.

I installed again cqrlog from repository and got running 2.0.5.(001) again.
While it installs it does something for file /etc/apparmor.d/usr.sbin.mysqld and then restarts apparmor (???? what I do not know yet)

After 2.0.5 was installed and tested to run ok I installed tgz over that install with the same console commands as above.

Then I got running 2.1.0(001) without any mysql errors. >
It seems to be right way to act at this case.

The good side doing it like this is that repository install does entry to start menu. Installing direct from tzg does not make a start menu entry. It has to be done manually.
How ever installing first from repository and then overlaying tgz keeps the start menu in place and working.

--
Saku
OH1KH

N4ULE
N4ULE's picture
MySQL

Did not get it going yet. It keeps telling my I have the wrong Ver of MySQL and I don't how to correct this problem. Thanks for trying to help.

73
N4ULE

Jim Quick
n4ule@sc.rr.com

ok7an
ok7an's picture
Re: MySQL

Did you try what I've posted before? It seems that after the upgrade there are both version of libmysql-client libraries 5.5 and 5.7. Use synaptic or uninstall libraries using apt remove libmysqlclient-5.5 or something like that.

N4ULE
N4ULE's picture
Thanks

Thanks to all who have worked with me in trying get CQRLOG and WSJT-X working. I now have the two programs working and talking to each other. So again I say thanks for all the help and advice to someone who new nothing about Linux. Without you I would still be in the dark.

73
Jim Quick / N4ULE
n4ule@sc.rr.com

Jim Quick
n4ule@sc.rr.com

G0DDZ
Upgrade won't start

I'm running a Raspberry Pi B+ with Raspbian Jessie. I've tried upgrading my cqrlog to both version 2.0.4 and 2.1.0. Neither will start. The 1.8.2 version will not allow me to change the time off field and if I update the LoTW and QSL manager lists, I get an "access violation" error and the program will not start. I have tried some of the fixes suggested and none of them have worked.