Bug while overwriting

5 posts / 0 new
Last post
ok1rr
ok1rr's picture
Bug while overwriting

The overwrite bug previously noticed in 2.1.0 remains. If I need to overwrite something in the logging window (RST, Name, QTH etc.) there is NOT overwritten the highlighted character but the next to them - ie. RST - when the default 599 (with the middle 9 highlighted) need to change to 579, the simple overwritting of the highlighted 9 results in 597 entry. The same applies to ANY field in the logging screen. This bug shows in the Debian Stretch 9 with Gnome, tests in older Ubuntu/Unity versions were OK.

It is apparently a Lazarus issue.

I reported this bug few months ago but badly surprised that it remains in 2.2.0.

73,
Martin, OK1RR

oh1kh
Bug while overwriting

Hi Martin!

Seems to be Lazarus and/or window manager issue.
Here, with Fedora 26/LXDE and home compiled (Lazarus 1.6.4) I could not produce that kind of bug.

Could you try my test binary (x86.64), it is the same I'm using myself and report does it the same bug when running in your system?
( http://www.saunalahti.fi/sakny/bin/cqrlog2/ ).
If it does, it is up to your window manager rather than Lazarus.

--
Saku
OH1KH

--
Saku
OH1KH

ok7an
ok7an's picture
Re: Bug while overwriting

Hi Saku,

actually it's a bug in Lazarus :(

https://forum.lazarus.freepascal.org/index.php?topic=35873.0

https://bugs.freepascal.org/view.php?id=30596

BTW new version is compiled in Lazarus 1.8.0 and fpc 3.0.4.

73 Petr

oh1kh
Argh.. Seems to be so.

Argh.. Seems to be so.

For getting more troubles I removed 3.0.2/1.6.4 and installed the latest ones.
Now I'm getting same kind of troubles. ( I still have binary from old compiler to use...and saved)

Now just sit and wait for fix to this...

--
Saku
OH1KH

--
Saku
OH1KH

ok1rr
ok1rr's picture
Re: Bug while overwriting {SOLVED]

Well done, Saku!

I tested the Saku's test binary from http://www.saunalahti.fi/sakny/bin/cqrlog2/ that is compiled with lazarus 1.6.4.
The nasty bug https://www.cqrlog.com/node/1943 does not exist anymore!

Can I suggest to 'officially' downgrade to Lazarus 1.6.4.? Possibly we need to release another build made in 1.6.4...