Input Echo

10 posts / 0 new
Last post
AD7GR
AD7GR's picture
Input Echo

I now have character echo on all input fields in CQRLog 2.2.0... command line, callsign entry, sign in to DX Cluster, etc. Perhaps I toggled something but I can't determine where that may have happened. This issue only occurs in CQRLog.

Ed - ad7gr

oh1kh
Input Echo

Hi Ed!

I have seen this happen before. But it was so long time ago that I really can't remember what caused it and how it was fixed.
I'm trying now to find an old version of Lazarus (164 or 162) for my Lubuntu 386 so that I could compile test binary also for 386.

I have a feeling that lazarus 1.8.0 used for compile of cqrlog 2.2.0-001 is making also other problems than cursor placement when editing input boxes.

--
Saku
OH1KH

AD7GR
AD7GR's picture
Hi Saku,

Hi Saku,

I hope there is a solution found soon... CQRLog is not usable until this typing echo effect is fixed.

73,
Ed - AD7GR

AD7GR
AD7GR's picture
Additional info:

Additional info:

Example: now instead of AD7GR when I type it in, I have AADD77GGRR shown in the Callbook support tab - user name field.

It was not like this at first since I was able to enter my station information okay.

Is it possible that I inadvertently changed something in LM Cinnamon 18.3 that is causing this issue for just CQRLog?

73,
Ed - AD7GR

oh1kh
Input echo

Hi Ed

Googled this. It is old, but could still be the reason. http://forum.lazarus.freepascal.org/index.php?topic=16585.0

--
Saku
OH1KH

AD7GR
AD7GR's picture
Saku, That may be the reason

Saku, That may be the reason but I used Petr's CQRLog 2.2.0 that he released the same day (2017-12-26) I got it. Odd though... when I clicked on Help --> About in CQRLOG the info there says 2.2.0 (001) with a date of 2017-12-30. Was it automatically updated? Is it possible my installation got corrupted somehow by that? I don't know and I don't know how to correct this issue.

73,
Ed - AD7GR

oh1kh
double echo

Hi Ed!

I released now test binary file for i386.
It is compiled with older lazarus (1.6.4/3.0.2) it may not help for this issue,
but you can try with it if nothing better is offered.

Find zip from http://www.saunalahti.fi/~sakny/bin/cqrlog2/
Please read text files from zip before doing anything else!

--
Saku
OH1KH

oh1kh
Input echo

Hi Ed!

I still suspect something like iBus if you say that is WAS working before.
I made a bit more Googling and found this: https://help.ubuntu.com/community/ibus

See "setting up your language" and "Using IBus" . If you can enter language setting you have IBus running and it MIGHT have been NOT running at the time cqrlog was working.

Have you done system updates (or are they set automatic) since cqrlog was still running ok?

You could reinstall cqrlog, but I suspect it does not help in any way.
This is something that is related to input method settings change or updates.

--
Saku
OH1KH

AD7GR
AD7GR's picture
Input echo

Hi Saku.

Yes, it must be something outside of CQRLog. Perhaps it's just a coincidence but I am also having problems with KeePassX, the Ctrl-V now minimizes it's window instead of auto-filling the login fields in the target login webpage.

In my reading I see that any issues have been in the older versions of lazarus, so I'm guessing that's probably not the cause.

Yes, I have done updates, including level 3 security updates, since CQRLoger was running okay.

Thank you for helping me in this... there is so much for me to learn.

73,
Ed - AD7GR

AD7GR
AD7GR's picture
Input Echo [Solved]

Hi Saku,

You were right... the cause was IBus. When I removed it the input echo stopped. Now I need to find out why KeePassX isn't working properly... but that's for another forum.

Thank you for your help in solving this!

73,
Ed - AD7GR