CQRLog Not Running after Ubuntu update

4 posts / 0 new
Last post
kb3tc
CQRLog Not Running after Ubuntu update

After installing the latest Ubuntu update (20.4 ?) my CQRLog doesn't run. Everything was good until then.
The message I get is MySQL could not be started, please check if the MySQL server is installed properly.
Please attach CQRLog Err log in this forum.
I am not real well versed with Linux so I need help in resolving this.
Help Please, Tim KB3TC
Email: kb3tc1@gmail.com

2020-10-10T19:32:40.086503Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.21-0ubuntu0.20.04.4) starting as process 2571
2020-10-10T19:32:40.087401Z 0 [Warning] [MY-013242] [Server] --character-set-server: 'utf8' is currently an alias for the character set UTF8MB3, but will be an alias for UTF8MB4 in a future release. Please consider using UTF8MB4 in order to be unambiguous.
2020-10-10T19:32:40.087409Z 0 [Warning] [MY-013244] [Server] --collation-server: 'utf8_general_ci' is a collation of the deprecated character set UTF8MB3. Please consider using UTF8MB4 with an appropriate collation instead.
2020-10-10T19:32:40.134907Z 1 [ERROR] [MY-011011] [Server] Failed to find valid data directory.
2020-10-10T19:32:40.135129Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
2020-10-10T19:32:40.135233Z 0 [ERROR] [MY-010119] [Server] Aborting
2020-10-10T19:32:40.135807Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.21-0ubuntu0.20.04.4) (Ubuntu).
2020-10-10T20:37:00.558804Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.21-0ubuntu0.20.04.4) starting as process 5470
2020-10-10T20:37:00.559851Z 0 [Warning] [MY-013242] [Server] --character-set-server: 'utf8' is currently an alias for the character set UTF8MB3, but will be an alias for UTF8MB4 in a future release. Please consider using UTF8MB4 in order to be unambiguous.
2020-10-10T20:37:00.559859Z 0 [Warning] [MY-013244] [Server] --collation-server: 'utf8_general_ci' is a collation of the deprecated character set UTF8MB3. Please consider using UTF8MB4 with an appropriate collation instead.
2020-10-10T20:37:00.565027Z 1 [ERROR] [MY-011011] [Server] Failed to find valid data directory.
2020-10-10T20:37:00.565213Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
2020-10-10T20:37:00.565287Z 0 [ERROR] [MY-010119] [Server] Aborting
2020-10-10T20:37:00.565568Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.21-0ubuntu0.20.04.4) (Ubuntu).
2020-10-11T14:17:26.344860Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.21-0ubuntu0.20.04.4) starting as process 2510
2020-10-11T14:17:26.345765Z 0 [Warning] [MY-013242] [Server] --character-set-server: 'utf8' is currently an alias for the character set UTF8MB3, but will be an alias for UTF8MB4 in a future release. Please consider using UTF8MB4 in order to be unambiguous.
2020-10-11T14:17:26.345773Z 0 [Warning] [MY-013244] [Server] --collation-server: 'utf8_general_ci' is a collation of the deprecated character set UTF8MB3. Please consider using UTF8MB4 with an appropriate collation instead.
2020-10-11T14:17:26.400573Z 1 [ERROR] [MY-011011] [Server] Failed to find valid data directory.
2020-10-11T14:17:26.400793Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
2020-10-11T14:17:26.400913Z 0 [ERROR] [MY-010119] [Server] Aborting
2020-10-11T14:17:26.401599Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.21-0ubuntu0.20.04.4) (Ubuntu).

NZ0T
You need to install mariahdb

You need to install mariahdb which will uninstall MySQL in it's place.

NZ0T
Install mariadb server-10.3

Install mariadb server-10.3 and that should fix it.

kb3tc
Fix for CQR Log ?

Bill,
I tried to get and install this program but I haven't had any success.
See the results of running it below.
Tim

tim@tim-XPS-8500:~/Desktop$ sudo apt install mariadb-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mariadb-server : Depends: mariadb-server-10.5 (>= 1:10.5.6+maria~focal) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
tim@tim-XPS-8500:~/Desktop$