You are here

Program locks up with rig control enabled

3 posts / 0 new
Last post
KB8HOC
Program locks up with rig control enabled

I'm running current cqrlog on Ubuntu 8.10. I have a Yaesu FT-950 and I've verified that hamlib is working very will with it (rigctl works fine and so do fldigi, etc).

Once I enable rig control in the software, the next time I open it the GUI opens but it just locks up. Here's the output of cqrlog -v:

[WARNING] Out of OEM specific VK codes, changing to unassigned
[WARNING] Out of OEM specific VK codes, assigning $FF
Starting CQRLOG ...
Config: /home/ryan/cqrlog/log_data/cqrlog.cfg

Thanks!
Ryan - KB8HOC

ok2cqr
ok2cqr's picture
RE: Program locks up with rig control enabled

Hi Ryan,

I'm sorry but I don't know what can be wrong. Please wait for version 0.7.0. I'm going to add trx control via rigctld. It is daemon created by hamlib developers and it should works very well. Now CQRLOG uses my own hamlib bindings and there is probably something wrong. I have sent question to hamlib mailing list and they didnt find anything wrong. So I don't know what can cause this problems.

If you can not start CQRLOG, please open configuration file cqrlog.cfg in log_data directory. Find and delete whole [TRX] section. If you could, please copy the section and paste here. Thank you.

73 Petr, OK2CQR

wc2l
Here is mine... I have the

Here is mine... I have the same issue on the FT1000 & FT950

[TRX]
port=/dev/ttyUSB0
speed=9600
Top=221
Left=1078
poll=1000
poll1=500
Speed1=4800
DataBits1=8
StopBits1=2
Handshake1=0
Parity1=0
Speed2=4800
DataBits2=8
StopBits2=1
Handshake2=2
Parity2=1
port1=/dev/ttyUSB0
poll2=500
dtr1=1
rts1=1
model1=103