Trx Rig Control setup

6 posts / 0 new
Last post
N3MOW
Trx Rig Control setup

Hello,
Trying to get trx-control to talk with my TS-570. I'm using a usb to serial cable. Have set device to /dev/ttyUSB0, speed 57.600, databits 8 and no parity. Port is set to 4532. Poll to 500. Other settings are to default. Radio is 204.
The radio is set for 57,600 and one stop bit. Note: I'm able to communicate with the radio in Ham Radio Deluxe. I have checked the active USB port and it shows the cable on ttyUSB0. As HRD is running under Wine I had to make a link (ln -s /dev/ttyUSB0 -> com3) in the .wine directory to get it to work. Tried setting trx to use com3 but that did not work.
Do I have to make a link and if so where? All suggestions are appreciated.
73
Marty, N3MOW
 

ok2cqr
ok2cqr's picture
RE: Trx Rig Control setup

Hi Marty,
 
please try to set only serial speed and leave other fields as "default". Maybe more com port prameters are not supported by hamlib for your radio. You can find out what is wrong when you run cqrlog --debug=1 from console.
 
73 Petr, OK2CQR

N3MOW
Re TX Rig control setup

Petr,
Tried your suggestion. No change. Ran debug. Looks OK. Could only get part of response from debug copied. Have pasted it here. Is it possible Hamlib is not installed? I've downloaded it but not sure how to install. Is it installed with CQR?
**** DEBUG LEVEL 1 ****
Loading libssl: /usr/lib/i386-linux-gnu/libssl.soLoading libcrypto: /usr/lib/i386-linux-gnu/libcrypto.soLoading libmysqlclient: /usr/lib/i386-linux-gnu/libmysqlclient.so.18.0.0Loaded 77420 LoTW usersLoaded 86141 eQSL usersLoaded 45414 SCP calls/home/marty/.config/cqrlog/database/marty-NC686AA-ABA-a6700y.pidCommand: kill 2457*User home directory:    /home/marty/Program home directory: /home/marty/.config/cqrlog/Data directory:         /home/marty/.config/cqrlog/database/Memebers directory:     /usr/share/cqrlog/members/ZIP code directory:     /usr/share/cqrlog/zipcodes/Binary dir:             /usr/bin/Share dir:              /usr/share/cqrlog/TConnection to MySQL:   5.5*select * from tables where table_schema = 'cqrlog_common'
SELECT log_nr,log_name FROM cqrlog_common.log_list order by log_nr
use cqrlog001
use cqrlog001
use cqrlog001
SELECT * FROM cqrlog_config
select * from db_version
select * from cqrlog_common.db_version
SELECT * FROM cqrlog_common.dxcc_ref ORDER BY ADIF
SELECT * FROM cqrlog_common.dxcc_ref ORDER BY ADIF
Settings:-----------------------------------------------------RigCtldPath:/usr/bin/rigctldRigCtldArgs:-m 204 -r /dev/ttyUSB0 -t 4532  -s 57600 RunRigCtld: FALSERigDevice:  /dev/ttyUSB0RigCtldPort:4532RigCtldHost:localhostRigPoll:    500RigSendCWR: FALSERigId:      204
rigctld started!Connected to localhost:4532
Settings:-----------------------------------------------------RotCtldPath:/usr/bin/rotctldRotCtldArgs:RunRotCtld: FALSERotDevice:  RotCtldPort:4533RotCtldHost:localhostRotPoll:    500RotId:      1
rotctld started!Connected to localhost:4533CW initSELECT * FROM profiles WHERE visible > 0 ORDER BY nr
SELECT * FROM profiles WHERE nr = 1
SELECT * FROM profil
73
Marty
 

Marty, N3MOW

N3MOW
Re TX Rig control setup

Hello,
Boy is my face red! I misssed the little box that said "start rig control with program". It works if you have rig control running. I have only the speed set all other parameters are set to default. Rig is 204.
Thanks for all responses. Issue appears to be solved.
Marty, N3MOW
 

Marty, N3MOW

sq9lbe
sq9lbe's picture
I seem to have a problem with

I seem to have a problem with TRX control. It worked a few times. After rebooting Linux Mint 18, or suspending, it won't connect to my rig.
I haven't changed any settings.
FLRIG connects to my radio with no problems.

Rig 122.

sq9lbe
sq9lbe's picture
SOLVED from my side ... I

SOLVED from my side ... I noticed that need to run CQRlog a short while after my rig. Now it sees my radio everytime.