Debian 9 Stable (Stretch)

6 posts / 0 new
Last post
ik1rac
ik1rac's picture
Debian 9 Stable (Stretch)

Hi Petr,
having trouble starting CQRLOG on a fresh install of debian 9 64 bit.
First I had to install libmariadb-dev-compat package but after that I now get:

Error during connection to database: TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).

Any ideas?

Thanks & 73

Log follows:

vittorio@ik1rac:~$ cqrlog --debug-1

(cqrlog:4127): Gtk-WARNING **: Impossibile trovare il motore del tema in module_path: «adwaita»,

(cqrlog:4127): Gtk-WARNING **: Impossibile trovare il motore del tema in module_path: «adwaita»,

**** DEBUG LEVEL 1 ****

SSL libraries:
/usr/lib/x86_64-linux-gnu/libssl.so.1.0.0
/usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.2
Loading libmysqlclient: /usr/lib/x86_64-linux-gnu/libmariadbclient.so.18
**************************
MySQL version: 10.
**************************
**********************************
MySQL version assigned: 5.6
**********************************
Loaded 73758 LoTW users
Loaded 103678 eQSL users
Loaded 44537 SCP calls
*
User home directory: /home/vittorio/
Program home directory: /home/vittorio/.config/cqrlog/
Data directory: /home/vittorio/.config/cqrlog/database/
Memebers directory: /usr/share/cqrlog/members/
ZIP code directory: /usr/share/cqrlog/zipcodes/
Binary dir: /usr/bin/
Share dir: /usr/share/cqrlog/
TConnection to MySQL: 5.6
*
56 us states loaded
WARNING: obsolete call to RecreateWnd for TfrmDBConnect
Warning: TWinControl.DestroyHandle frmDBConnect:TfrmDBConnect Handle not Allocated
/usr/sbin/mysqld --defaults-file=/home/vittorio/.config/cqrlog/database/mysql.cnf --datadir=/home/vittorio/.config/cqrlog/database/ --socket=/home/vittorio/.config/cqrlog/database/sock --port=64000
Trying to connect to database
2017-07-22 14:41:56 140480187339328 [Note] /usr/sbin/mysqld (mysqld 10.1.23-MariaDB-9+deb9u1) starting as process 4130 ...
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:1
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:2
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:3
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:4
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:5
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:6
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:7
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:8
WARNING: obsolete call to RecreateWnd for TfrmDbError
Warning: TWinControl.DestroyHandle frmDbError:TfrmDbError Handle not Allocated

ok7an
ok7an's picture
Re: Debian 9 Stable (Stretch)

Hi,

I know about this problem but unfortunately it's not a bug in CQRLOG. The bug is in FreePascal compiler that doesn't have support for MariaDB. It's very strange because the same version in Ubuntu or other distribution has the MariaDB support build-in. Please use binaries from Download section, they will work.
I hope the bug in fpc will be fixed soon.

73 Petr, OK7AN

g8tmv
cqrlog in stretch is out of date

Unfortunately the version of cqrlog in stretch is out of date, as Petr says, for now please use the version from Downloads or the version from Debian testing

ik1rac
ik1rac's picture
I tried with cqrlog-2.0.5-2

I tried with cqrlog-2.0.5-2 but still I get errors ...

qrlog --debug-1

(cqrlog:7501): Gtk-WARNING **: Impossibile trovare il motore del tema in module_path: «adwaita»,

(cqrlog:7501): Gtk-WARNING **: Impossibile trovare il motore del tema in module_path: «adwaita»,

**** DEBUG LEVEL 1 ****

SSL libraries:
/usr/lib/x86_64-linux-gnu/libssl.so.1.0.0
/usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.2
Loading libmysqlclient: /usr/lib/x86_64-linux-gnu/libmariadbclient.so.18
**************************
MySQL version: 10.
**************************
**********************************
MySQL version assigned: 5.6
**********************************
Loaded 73758 LoTW users
Loaded 103678 eQSL users
Loaded 44537 SCP calls
*
User home directory: /home/vittorio/
Program home directory: /home/vittorio/.config/cqrlog/
Data directory: /home/vittorio/.config/cqrlog/database/
Memebers directory: /usr/share/cqrlog/members/
ZIP code directory: /usr/share/cqrlog/zipcodes/
Binary dir: /usr/bin/
Share dir: /usr/share/cqrlog/
TConnection to MySQL: 5.6
*
56 us states loaded
WARNING: obsolete call to RecreateWnd for TfrmDBConnect
Warning: TWinControl.DestroyHandle frmDBConnect:TfrmDBConnect Handle not Allocated
/usr/sbin/mysqld --defaults-file=/home/vittorio/.config/cqrlog/database/mysql.cnf --datadir=/home/vittorio/.config/cqrlog/database/ --socket=/home/vittorio/.config/cqrlog/database/sock --port=64000
Trying to connect to database
2017-07-29 17:57:30 140641957450304 [Note] /usr/sbin/mysqld (mysqld 10.1.23-MariaDB-9+deb9u1) starting as process 7504 ...
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:1
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:2
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:3
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:4
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:5
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:6
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:7
Trying to connect to database
TMySQL56Connection can not work with the installed MySQL client version: Expected (5.6), got (5.5.1).
Trying:8
WARNING: obsolete call to RecreateWnd for TfrmDbError
Warning: TWinControl.DestroyHandle frmDbError:TfrmDbError Handle not Allocated
Closing DXCluster window
Closing TRXControl window
Closing GrayLine window
Closing dDXCC
Closing dData
/home/vittorio/.config/cqrlog/database/ik1rac.pid
Command:
kill 7504
Closing ini file ...
Invalid file handle
Cheers

g8tmv
libmariadbclient-dev-compat required

Because of a problem in the Free Pascal compiler you currently need an extra dependency installed. Please install libmariadbclient-dev-compat

apt-get install libmariadbclient-dev-compat

Colin G8TMV

ik1rac
ik1rac's picture
Many thanks

Sorry Colin,
very rude of me. I was sure I already thanked you.
That was it! Problem solved.
73s