ADIF import and installing 2.5.2

3 posts / 0 new
Last post
mi0hoz
ADIF import and installing 2.5.2

I'm using Ubuntu 21.04 and Cqrlog 2.5.1
I tried to import an adif file and it reports no errors but won't import anything. I've tried creating a new log and importing various adif files including my backup file. I then found out there was a new version of Cqrlog, 2.5.2, so I tried to install it but get the following error message: The following packages have unmet dependencies.
cqrlog : Depends: libhamlib2 (>= 1.2.10) but it is not installable
Depends: libmariadbclient-dev but it is not installable
E: Unable to correct problems, you have held broken packages.

Any ideas?

Mick

oh1kh
ADIF import and installing 2.5.2

HI Mick!

The adif bug is fixed 2021-07-07 so it is not in 2.5.2 package yet. This leaves two options for you:

1) Compile from latest source. It is not difficult but needs a bit command terminal usage.
At least following messages have instructions how to compile cqrlog from source:

Raspberry PI 4 and cqrlog https://www.cqrlog.com/node/3124
New Ubuntu and latest cqrlog https://www.cqrlog.com/node/2984
Mint 20 Cinnamon and new cqrlog https://www.cqrlog.com/node/2998

2) Update your current cqrlog using ready compiled binary file and install script that does the job. See the README for install with script, or completely manual way, from address https://github.com/OH1KH/cqrlog/tree/loc_testing/compiled

--
Saku
OH1KH

mi0hoz
ADIF import and installing 2.5.2

Saku, compiled and installed and everything working great. Many thanks.

Mick, MI0HOZ