solved (self) - Ubuntu 21.04 and mariadb 10.5

3 posts / 0 new
Last post
dl2new
solved (self) - Ubuntu 21.04 and mariadb 10.5

PPA deactivated with "Alt-F2-software-properties-gtk"
---
I upgraded my system to Ubuntu 21.04. Now I have problems to install cqrlog. Mariadb is v10.5.
Cqrlog has a dependency to "libmariadbclient-dev" but it is not aailable in v10.5.
Any ideas?
Thanks.
Sven

sven@nuc6i5-sven:~$ sudo apt-get install cqrlog
[sudo] password for sven:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
cqrlog : Depends: libmariadbclient-dev but it is not installable
E: Unable to correct problems, you have held broken packages.
sven@nuc6i5-sven:~$
sven@nuc6i5-sven:~$
sven@nuc6i5-sven:~$ sudo apt-get install libmariadbclient-dev
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package libmariadbclient-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libmariadb-dev-compat libmariadb-dev

E: Package 'libmariadbclient-dev' has no installation candidate
sven@nuc6i5-sven:~$

oh1kh
solved (self) - Ubuntu 21.04 and mariadb 10.5

HI Sven!

Fine that you solved it.
We would appreciate it if you would tell how you did it just by dropping line or two here. It might then help others having same kind of problem.

Thank you !

--
Saku
OH1KH

w6bvb
How you resolve the issue?

How you resolve the issue?